#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"Grade\s*=\s*(?P<grade>.+)" & @CRLF & _
"(?P<students>[\s\S]+?)" & @CRLF & _
"(?=^Grade|\Z)"
Local $sString = "School = Riverdale High" & @CRLF & _
"Grade = 1" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Phoebe" & @CRLF & _
"1, Rachel" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 3" & @CRLF & _
"1, 7" & @CRLF & _
"" & @CRLF & _
"Grade = 2" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Angela" & @CRLF & _
"1, Tristan" & @CRLF & _
"2, Aurora" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 6" & @CRLF & _
"1, 3" & @CRLF & _
"2, 9"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")