import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "Grade\\s*=\\s*(?P<grade>.+)\n"
+ "(?P<students>[\\s\\S]+?)\n"
+ "(?=^Grade|\\Z)";
final String string = "School = Riverdale High\n"
+ "Grade = 1\n"
+ "Student number, Name\n"
+ "0, Phoebe\n"
+ "1, Rachel\n\n"
+ "Student number, Score\n"
+ "0, 3\n"
+ "1, 7\n\n"
+ "Grade = 2\n"
+ "Student number, Name\n"
+ "0, Angela\n"
+ "1, Tristan\n"
+ "2, Aurora\n\n"
+ "Student number, Score\n"
+ "0, 6\n"
+ "1, 3\n"
+ "2, 9";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}