import re
regex = re.compile(r"""
^
Grade\s*=\s*(?P<grade>.+)
(?P<students>[\s\S]+?)
(?=^Grade|\Z)
""", flags=re.MULTILINE | re.VERBOSE)
test_str = ("School = Riverdale High\n"
"Grade = 1\n"
"Student number, Name\n"
"0, Phoebe\n"
"1, Rachel\n\n"
"Student number, Score\n"
"0, 3\n"
"1, 7\n\n"
"Grade = 2\n"
"Student number, Name\n"
"0, Angela\n"
"1, Tristan\n"
"2, Aurora\n\n"
"Student number, Score\n"
"0, 6\n"
"1, 3\n"
"2, 9")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")