#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"Student\ number,\ Name[\n\r]" & @CRLF & _
"(?P<student_names>(?:^\d+.+[\n\r])+)" & @CRLF & _
"\s*" & @CRLF & _
"^" & @CRLF & _
"Student\ number,\ Score[\n\r]" & @CRLF & _
"(?P<student_scores>(?:^\d+.+[\n\r])+)"
Local $sString = "Grade = 1" & @CRLF & _
"Student number, Name" & @CRLF & _
"0, Phoebe" & @CRLF & _
"1, Rachel" & @CRLF & _
"" & @CRLF & _
"Student number, Score" & @CRLF & _
"0, 3" & @CRLF & _
"1, 7" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")