import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\n"
+ "Student\\ number,\\ Name[\\n\\r]\n"
+ "(?P<student_names>(?:^\\d+.+[\\n\\r])+)\n"
+ "\\s*\n"
+ "^\n"
+ "Student\\ number,\\ Score[\\n\\r]\n"
+ "(?P<student_scores>(?:^\\d+.+[\\n\\r])+)";
final String string = "Grade = 1\n"
+ "Student number, Name\n"
+ "0, Phoebe\n"
+ "1, Rachel\n\n"
+ "Student number, Score\n"
+ "0, 3\n"
+ "1, 7\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}