$re = '/^(.*?)(?:_v0*(\d+))?$/m';
$str = 'abc_v0001
abc_v10000
abc_vwx_v0001
abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);