#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)t"
Local $sString = "// 提取金额" & @CRLF & _
"v me $50" & @CRLF & _
"v me $1.5" & @CRLF & _
"v me $-50" & @CRLF & _
" " & @CRLF & _
"// 只匹配上面的金额" & @CRLF & _
"---分割线---" & @CRLF & _
" " & @CRLF & _
"v me $1. " & @CRLF & _
"v me $.5" & @CRLF & _
"v me $.22" & @CRLF & _
"v me $22." & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")