package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)t`)
var str = `// 提取金额
v me $50
v me $1.5
v me $-50
// 只匹配上面的金额
---分割线---
v me $1.
v me $.5
v me $.22
v me $22.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}