import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "t";
final String string = "// 提取金额\n"
+ "v me $50\n"
+ "v me $1.5\n"
+ "v me $-50\n"
+ " \n"
+ "// 只匹配上面的金额\n"
+ "---分割线---\n"
+ " \n"
+ "v me $1. \n"
+ "v me $.5\n"
+ "v me $.22\n"
+ "v me $22.\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}