re = /.*(\.[^\.\(]*)\1\(.*/
str = 'ns1.Class1.Class1()
ns1.Class1.Print(
ns2.Class2.Class2()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end