Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Regular
Expressions
101
Regular
Expressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
([A-z])((?![A-z]{2,3}$)\w){2,3}
/
gm
Test String
New
Bt12 bt12 bte2 bt1 b123 b12 Bte 1bt 123 b1 abcd 12 ab