#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?::keyword_start:|\G(?!^)\S+)\K(?<!_end:)\s+"
Local $sString = "This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex"
Local $sSubst = " "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)