re = /(?::keyword_start:|\G(?!^)\S+)\K(?<!_end:)\s+/
str = 'This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex'
subst = ' '
result = str.gsub(re, subst)
# Print the result of the substitution
puts result