import Foundation
let pattern = #"(?::keyword_start:|\G(?!^)\S+)\K(?<!_end:)\s+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"This is a teststring ... :keyword_start: this is the content with double spaces :keyword_end: more text ... :keyword_start: this is the second content with double spaces :keyword_end: ... more tex"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #" "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)