re = /<\/?[b|B][r|R] ?\/?>/m
str = '<br />
<br/>
</br>
<br>
<BR>
</BR>
<BR/>
<BR />
br
<br >
<bb/>
<br />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end