#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "data\[(\d{1,3})\](?![\s\S]*data\[\d{1,3}\])"
Local $sString = "<body>" & @CRLF & _
"<h2>JavaScript Regular Expressions</h2>" & @CRLF & _
"<p>TEST</p>" & @CRLF & _
"<p>data[01]</p>" & @CRLF & _
"<button onclick="myFunction()">Try it</button>" & @CRLF & _
"<p>data[02]</p>" & @CRLF & _
"<p>TEST</p>" & @CRLF & _
"<p id="demo" test=data[03]></p>" & @CRLF & _
"</body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")