using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((^)|(\<\/table\>))(.*?)((\<table\>)|($))";
string substitution = @"\4";
string input = @"dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}