re = /((^)|(\<\/table\>))(.*?)((\<table\>)|($))/
str = 'dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa'
subst = '\\4'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result