// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"((^)|(\<\/table\>))(.*?)((\<table\>)|($))").unwrap();
let string = "dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa";
let substitution = "\\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}