import Foundation
let pattern = #"((^)|(\<\/table\>))(.*?)((\<table\>)|($))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)