#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)<span class="placeholder" code="(.*?)">(?:.*)<\/span>"
Local $sString = "<p>k</p><p><span class="placeholder" code="{YSZZ}">Samsung xyz</span> </p><p>khgj <span class="placeholder" code="{UIDJU}">iPhone 9k</span> </p></div>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")