package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)<span class="placeholder" code="(.*?)">(?:.*)<\/span>`)
var str = `<p>k</p><p><span class="placeholder" code="{YSZZ}">Samsung xyz</span> </p><p>khgj <span class="placeholder" code="{UIDJU}">iPhone 9k</span> </p></div>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}