$re = '/<span class="placeholder" code="(.*?)">(?:.*)<\/span>/i';
$str = '<p>k</p><p><span class="placeholder" code="{YSZZ}">Samsung xyz</span> </p><p>khgj <span class="placeholder" code="{UIDJU}">iPhone 9k</span> </p></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);