re = /require_once . \$doc_root .\.. (\\)"/mix
str = 'require_once $doc_root . "\\inc\\common.php";
require_once $doc_root . "\\inc\\admin_login.php";
require_once $doc_root . "\\inc\\usps_functions.php";
require_once $doc_root . \'\\lib\\PDFMerger\\PDFMerger.php\';'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end