import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(script)([^\\/>]*?)>((\\s|.)*?)<\\/script\\s?>";
final String string = "<script type=3D\"text/javascript\">hsjQuery =3D window['jQuery']</script>\n\n"
+ "<script type=3D\"textjavascript\">hsjQuery = 1 / 2</script>\n\n"
+ "<script type=3D\"text/javascript\"/>hsjQuery = 1 / 2</script>\n\n"
+ "<script type=\"textjavascript\">asdgsdgs</script>\n\n"
+ "<script />\n"
+ "<script>lala</script>";
final String subst = "<ff-$1 style='display: none;'$2>$3</ff-$1>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}