$re = '/(?s)(.{10,})\s*(?:\1)+/';
$str = 'I would like this
text to be
reduced
I would like this
text to be
reduced';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;