import Foundation
let pattern = #"(\b.+?\b)\1\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
are blue and then and then very bright
are blue and then a and then very bright
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)