using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bcool\b(?:(?!\b(cool|good)\b).)*\bgood\b";
string input = @"cool randomtext1 cool randomtext2 cool randomtext3 good cool";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}