$re = '/\bcool\b(?:(?!\b(cool|good)\b).)*\bgood\b/';
$str = 'cool randomtext1 cool randomtext2 cool randomtext3 good cool';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);