re = /\bcool\b(?:(?!\b(cool|good)\b).)*\bgood\b/
str = 'cool randomtext1 cool randomtext2 cool randomtext3 good cool'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end