$re = '/x-client-ip=([0-9]+\.){1,3}[0-9]{1,3}/';
$str = 'x-client-ip=10.90.0.254';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);