#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<serialCode>[a-zA-Z0-9]{0,3})(?:(?<serialMarket>[a-zA-Z]{1,2})(?<serialSuffix>(?<=^.{5})[a-zA-Z0-9]*)?)?"
Local $sString = "abcfobar" & @CRLF & _
"abc33bar" & @CRLF & _
"abca3bar" & @CRLF & _
"abc3abar" & @CRLF & _
"" & @CRLF & _
"ab3abar" & @CRLF & _
"c3abar" & @CRLF & _
"3abar" & @CRLF & _
"bar" & @CRLF & _
"" & @CRLF & _
"ab3a3ar" & @CRLF & _
"c3ab4r" & @CRLF & _
"3aba4" & @CRLF & _
"bar" & @CRLF & _
"" & @CRLF & _
"234f22fsdf" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"a23a3ar" & @CRLF & _
"c3ab4r" & @CRLF & _
"3aba4" & @CRLF & _
"bar" & @CRLF & _
"" & @CRLF & _
"@saff" & @CRLF & _
"a@" & @CRLF & _
"4@" & @CRLF & _
"ab@" & @CRLF & _
"abc@" & @CRLF & _
"abcd@f" & @CRLF & _
"avcde@" & @CRLF & _
"abcdef@" & @CRLF & _
"abcdefg@"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")