Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(\d+)(\,\d+\s)?m[2²]
/
gm
Input 1
1
New
appartement de 4 pièces, 2 chambres, 71,52 m² appartement de 2 pièces, 1 chambre, 55m²