const regex = /^\s*(?:
(?<protocol>https?)
\:[\/\\]{2}
(?<app>[\w\-]+)
\.
(?<client>[\w]+)
\-?
(?<environment>[\w]*)
\.
(?<audience>[\w\.]+)
\:?
(?<port>\d*)
[\\\/]
(?<instance>.*?)
)\s*$
/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*(?:
(?<protocol>https?)
\\:[\\\/\\\\]{2}
(?<app>[\\w\\-]+)
\\.
(?<client>[\\w]+)
\\-?
(?<environment>[\\w]*)
\\.
(?<audience>[\\w\\.]+)
\\:?
(?<port>\\d*)
[\\\\\\\/]
(?<instance>.*?)
)\\s*$
', 'gmi')
const str = `https://pii.ngkf-qa.commloanservices.com/qa2
https://pii.ngkf-qa.pncint.net/qa1
https://wlm-app.midlandls-qa.pncint.net/qa1-fdic
https://wlm-app.midlandls-qa.pncint.net/qa2fdic `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}