use strict;
my $str = 'https://pii.ngkf-qa.commloanservices.com/qa2
https://pii.ngkf-qa.pncint.net/qa1
https://wlm-app.midlandls-qa.pncint.net/qa1-fdic
https://wlm-app.midlandls-qa.pncint.net/qa2fdic ';
my $regex = qr/^\s*(?:
(?<protocol>https?)
\:[\/\\]{2}
(?<app>[\w\-]+)
\.
(?<client>[\w]+)
\-?
(?<environment>[\w]*)
\.
(?<audience>[\w\.]+)
\:?
(?<port>\d*)
[\\\/]
(?<instance>.*?)
)\s*$
/mxip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}