package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(resume|posting) (\d+)(?:.*?in ([\d.]+) secs)?`)
var str = `Created posting 187294181 (sny/sny_AF8F46748A50416A9F1FF2BD7) in 0.261 secs
Created posting 187294183`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}