import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(resume|posting) (\\d+)(?:.*?in ([\\d.]+) secs)?";
final String string = "Created posting 187294181 (sny/sny_AF8F46748A50416A9F1FF2BD7) in 0.261 secs\n"
+ "Created posting 187294183";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}