const regex = new RegExp('(resume|posting) (\\d+)(?:.*?in ([\\d.]+) secs)?', 'gm')
const str = `Created posting 187294181 (sny/sny_AF8F46748A50416A9F1FF2BD7) in 0.261 secs
Created posting 187294183`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}