use strict;
my $str = 'Created posting 187294181 (sny/sny_AF8F46748A50416A9F1FF2BD7) in 0.261 secs
Created posting 187294183';
my $regex = qr/(resume|posting) (\d+)(?:.*?in ([\d.]+) secs)?/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}