$re = '/(?im)^(?:The |a )\K\w{3}/';
$str = 'The firstMatch
A SecondMatch
the thirdMatch
a Fourthmatch';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);