#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "csrftoken=([\w]+)\;"
Local $sString = "Set-Cookie: csrftoken=bf8748c0b1e113430d9757cf0ed06f4a; expires=Mon, 04-May-2015 20:54:08 GMT; Max-Age=31449600; Path=/"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")