using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"csrftoken=([\w]+)\;";
string input = @"Set-Cookie: csrftoken=bf8748c0b1e113430d9757cf0ed06f4a; expires=Mon, 04-May-2015 20:54:08 GMT; Max-Age=31449600; Path=/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}