re = /csrftoken=([\w]+)\;/
str = 'Set-Cookie: csrftoken=bf8748c0b1e113430d9757cf0ed06f4a; expires=Mon, 04-May-2015 20:54:08 GMT; Max-Age=31449600; Path=/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end