#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?!-([ABC])(\d{3})).)*$"
Local $sString = "02731043-V2024" & @CRLF & _
"02731043*-V2024" & @CRLF & _
"02731043*-I2024" & @CRLF & _
"3423432fffetertetg02731043*-V2024" & @CRLF & _
"02731043" & @CRLF & _
"02731043*"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")