using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<[a-z]+:\sname=""[a-zA-Z]+""\scontent="".+""\s(?:\/|)>";
string input = @"<a: name=""Var"" content=""Value"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}