re = /<[a-z]+:\sname="[a-zA-Z]+"\scontent=".+"\s(?:\/|)>/
str = '<a: name="Var" content="Value" />'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end