import Foundation
let pattern = #"^[A-Za-z0-9+\/]{22}==$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/*Base64 encoded object GUID*/
z5mytpY3n0uS7WotFo0XPQ==
y1NiJQ4GvkOc6Sza75j61A==
LGRAKG1ns0u0i7HlruqP3Q==
QOrSNu771Eyc8xQ2pS1jFg==
X9wPxWuMukaZZyDBof7znw==
lQk7QUbexkGt8s6xEu0UoA==
lQk7QUbexkGt8s6xEu0UoA==
lQk7QUbexkGt8s6xEu0UoA==
FCE4wll/okm/2Hgp2cdmMg==
qAzTWmiXT0SHg2sh9h2r8g==
ksVRSMPQhEGrcm6giubf1w==
2BB+XUPh/0mdSrk7tcoi9g==
PtsmDdnwwkKMIOpifql3EQ==
10hez6mxQk+PGIwoNvIzWg==
sr9hU+51nUClfMW/rs6Sog==
zqVrydHA/UqX1OH+TZaaNg==
mL5TJlQ2U0euhNgPXRKcyA==
z5mytpY3n0uS7WotFo0XPQ==
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)