use strict;
my $str = '<div this-html="text goes here!" class="something">test</div><div this-html="another test">Option is visible on preview/publish</div>';
my $regex = qr/(<\s*(\w+)[^<]*?)\s+this-html=['"]([^"']*)['"]([^>]*?)\s*>[\w\W]*?(<\/\2>)/mp;
my $subst = '$1$4>$3$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";