# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(<\s*(\w+)[^<]*?)\s+this-html=['\"]([^\"']*)['\"]([^>]*?)\s*>[\w\W]*?(<\/\2>)"
test_str = "<div this-html=\"text goes here!\" class=\"something\">test</div><div this-html=\"another test\">Option is visible on preview/publish</div>"
subst = "$1$4>$3$5"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.