using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:(?![×Þß÷þø])[-0-9a-zÀ-ÿ.])+\.(?:[a-z])+?$";
string input = @"facebook.com
facebook-test.com
bbc.co.uk
bbc-test.co.uk
192.168.0.1
0.1
ee-outage.s3.amazonaws.com
an-éxample-domain.com
an-x%mple-domain.com
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvwxyz
abcdefghijklmonpqrstuvwxyz012345678910abcdefghijklmonpqrstuvw.xyz
my'domain.com";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}